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Course Introduction 
Welcome to the Web Development Workshop.  This course is designed to explain the basics of 
web site development including site design, site development with FrontPage 98, basic graphics, 
and publishing pages.  To get the most out of this course you should have a good understanding of 
HTML and the World Wide Web.   

The course is taught through demonstrations and hands-on exercises.  In addition to this handout 
two books will be used during this course - FrontPage 98 Unleashed- 3rd Edition and The 
Non-Designers Web Book. 

The exercises will step you through the process of creating a web site from the ground up.  
Concepts and techniques are presented then you are given a chance to practice.  As you progress 
through the exercises you will be creating a web site about Coast Guard vessels and aircraft.  To 
create your site you will use FrontPage for site design and development and Micrografx Picture 
Publisher for creating graphics. 

Objective 
Using FrontPage and Micrografx Picture Publisher you will be able to create and manage web sites 
that conform to USCG Policy and include the following: 

♦ Original images 
♦ Frames 
♦ FrontPage Components 

Policies 
Because the pages you create will be posted on USCG servers it is important that you understand 
the policies for posting pages and page content. There are two options for posting pages- the Coast 
Guard Internet server at OSC and the Intranet server here at TRACEN Petaluma.  Where you post 
your pages will determine, in part, what you can and can’t do with your pages.   

This course assumes you will be creating pages for the Intranet, but you should be familiar with 
policies for both Internet and Intranet pages. 

Section 

1 
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Internet 
Pages that are posted to the server at OSC are required to conform to content guidelines explained 
in COMDTINST 5230.56.  Additionally the webmasters at OSC have placed technical restrictions 
on pages.  Pages will not include any active elements.  This includes the following: 

♦ ActiveX components 
♦ Interactive forms 
♦ FrontPage components that require the FrontPage server extensions 

♦ Other FrontPage enhancements that require directories starting with the underscore 
character ( e.g. _private) 

♦ CGI or PERL scripts 

Your pages must be static pages that use standard HTML.  The only types of files that you can post 
are: 

♦ .htm 
♦ .html 
♦ .txt. 
♦ .gif 
♦ .jpg 
♦ .pdf 

The URL for the Coast Guard homepage is www.uscg.mil.  Training Center Petaluma's URL is 
www.uscg.mil/hq/tcpet. 

Intranet 
Pages posted to the Intranet server must conform to content and style guidelines established in 
COMDTINST 5230.57.  Currently there are no technical restrictions on what you can and can’t 
post, but all pages that contain active elements will be reviewed by the webmaster to ensure they 
will not cause any conflicts. You should check with the base webmaster before implementing any 
active elements on your pages.   

Setting Up 
Before starting the exercises there are a couple things that need to be done.  You will need to map a 
network drive and copy some practice files.  To do this, follow the steps on the next page. 
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Mapping G:\ 
1. Open My Computer . 
2. Make sure the Toolbar is visible.  If it is not, from the View menu choose Toolbar. 
3. Click the Map Network Drive button. 
4. In the Drive box select G:\   

NOTE: You must use G:\ 
5. In the path box type \\petaluma01\users1 

6. Click the box next to Reconnect at Logon.  The box will be checked.  Your screen 
should look exactly like the example below. 

 
7. Click OK.  The drive will be connected.  A window for the drive should open. 

Copying Files 
1. Open Network Neighborhood . 
2. Open Petaluma01. 
3. Open the folder SWIII Training. 
4. Open the folder Practice Exercises. 
5. Locate and copy the folder Web Workshop to your U:\ drive. 



44  

Web Site Design 
The word design means many things to many different people.  Some think of graphic designers 
who design layouts for printed materials as well as graphic images.  If you are an instructor you 
might think of instructional designers who develop training.  When we talk about design in 
interactive media, we really are talking about three different types of design- information design, 
interaction design, and visual design.  All three are distinctly different, but interrelated.  Also, each 
one is equally important. 

Information Design 
Information design should be the first step in creating a web site. Information design is where you 
decide the content and purpose of the site.  Information design is mostly analysis and research to 
determine what your site will include.  This includes determining the purpose of the site, the 
audience, what the content should be and how it is organized, and what resources you have 
available to develop the site. For instructional sites, this is generally accomplished through front-
end analysis and curriculum design.   

Some questions you would ask during information design include: 
♦ What is the purpose of the site? 
♦ Who do I want to look at this site? 
♦ Why should they look at this site? 
♦ What information do I want to include and how will it be organized? 
♦ How can I actually get the site finished? 

 

Content Design 
Part of information design is Content Design.  Content design is really just determining what you 
want to include in your site and how you want to organize it.  You don't have to have all the 
content you want to include, but you should have a complete content outline.   

Once you have an outline, create a flowchart to show how the content is tied together.  Remember 
that the web is not linear.  People do not have to start at page one like they do in a book.  You 
should have a home page, but from there the path people take may not be linear.  

Section 
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If you can create a flowchart for your site, you essentially have a site map.  You don't yet know 
how the pages will look, but you know what pages you need and how they are organized.  This 
serves as the blue print, or skeleton of your site.  A blue print for a house tells you everything that 
will be in the house and how it is laid out. For example it shows how many bathrooms are 
included and where they are.  You may not know what color the walls will be or what type of 
fixtures will be used, but you do know how many bathrooms and what each one includes.  As you 
proceed through interaction design and visual design the blue print will become more detailed. 

 

Production Plan 
Along with your blue print for the site, you need to develop a plan to actually build the site.  
Typically large sites will require several people working as a team, much like building a house 
requires many people.  You will need people to help author web pages, create graphics, write 
content, and review the pages.  Also, don't forget you need someone to manage this project.  And 
don't think you can do it all yourself.  You might be able to with a small site, but with large sites 
you will need to work as a team. 

You will also need to determine how you will get the elements that you need.  For example your 
may require photos in your site.  Who will take the pictures and how will they get onto a 
computer?  Do you need access to a scanner or a digital camera?  Are you going to include 
illustrations, charts, or graphs, if so who will create them?  Do you need to get copyright 
permission for some content?  Do you have enough computers to do all this work?  Where will 
your pages be posted and does the webmaster know what you're doing?  Oh yeah, be sure to read 
the Commandant Instructions for the Internet and Intranet. 

In other words, make plans before you start work.  The more planning you do, the easier you 
project will be.  And write everything down.  You absolutely must document everything. All the 
documentation will be used as a guide for building the site.  Six months or a year down the road 
you will need the documentation for something, I guarantee it. 

Interaction Design 
Interaction design overlaps a lot with information design.  Interaction design is basically 
determining how people move around your site.  Sounds simple, you just provide some links to 
click, right? Yes, but interaction design is much more than just creating links.  To make your site 
effective you really need to plan the interaction.  Every link on your page must serve a purpose.  
Every link should also make sense.  In other words, link when appropriate, and only when 
appropriate.  Interaction design is creating the entire navigation scheme of your site that makes 
sense to users 

There are several things you must consider when creating your navigation.  First and foremost, it 
should be based on your flowchart.  If you look at your flowchart you should see the basic 
navigation of the site.  Some other considerations to think about are: 

♦ You should link to the home page from every page. 
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♦ The home page only needs to link to the next level down. 
♦ Will you include a site map? 
♦ You should include an email link on every page. 
♦ Are there links that need to be on every page, no matter how far down? 
♦ Do you have a feedback page? 

♦ Will parent pages only link to child pages, or will they link across to other pages at the 
same level? 

♦ Will child pages link only to parent pages, or to other child pages. 
♦ Aside from the navigation structure, what other links do you need? 
♦ How will you link to other sites, if at all? 

 

A good rule of thumb is to keep the navigation simple, while still allowing the user freedom.   

Also, think in terms of page types.  The home page will most likely have navigation different from 
other pages.  Each section of your site will have an index page with similar links.  Pages that are 
just content will have different links than section index pages.  Although different page types will 
have different links, it is important that you stay consistent with the links on each type of page.  
For example, if on one section index page you have a link to the other section index pages, then all 
section index pages should have link to each other. 

Again, write down your navigation plan.  You and your team will need to refer to it often.  This 
just adds more detail to your blueprint. 

Visual Design 
Now that you know what will be in your site and how people will navigate through it, you need to 
determine how it will look.  This is the visual design of the site.  It includes color scheme, page 
layout, and graphic design.  It also incorporates the decisions you made during information design 
and interaction design. 

When designing the look of your site there are four basic design principles that if you stick to, you 
should be able to create visually appealing sites.  These are alignment, proximity, repetition, and 
contrast.  The principles are covered in detail in The Non-Designers Web Book in Chapter 6 
starting on page 105. 

Alignment 
Alignment means that all elements on a page are aligned with each other.  It is easy to align text 
and images on a web page, so it is easy to use many different types of alignment.  As a rule of 
thumb, pick one alignment and stick with it.  Don't mix alignments. 

Having everything use the same alignment will make your pages cleaner and easier to read.  
Alignment will add order and consistency to your pages. 
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Proximity 
Proximity means that related elements should be close to each other.  That's all proximity means.  
Take a look at the examples below.  In the first example the words "Aligning Graphics" are not in 
close proximity to the paragraph.  In the second example the paragraph heading is directly above 
the paragraph.  Visually you can see these things belong together 

 

Example 1-The paragraph heading is not grouped with the paragraph 

 
Example 2 - The paragraph heading is with the paragraph  

Repetition 
Repeating elements throughout a web site adds consistency.  Repetition is a powerful way to 
ensure all your pages go together, at least visually.  To build consistency you can do simple things, 
like use the same background on every page or always use the same font for certain elements.   

Page layout is the best way to use repetition.  All pages in a site should have the same or similar 
layout.  This provides continuity among pages and makes them easier to use.  People like familiar 
things, so all your pages should look similar. You can also use repetition within a page.  For 
example, all your paragraph headings can be the same font and color. 

Navigation elements are also an easy way to use repetition.  You should use the same navigation 
scheme on every page.  If you place your navigation bars in the same place on every page people 
become comfortable with the pages because they know where to look for links to other pages. 

A good way to ensure all your text is the same is to use a cascading style sheet or a FrontPage 
Theme.  These will be discussed later.  Both offer easy ways to use repetitive styles on your pages. 
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Contrast 
Contrast draws your eye to the page, or to elements on the page.  You can use contrast to create 
focal points on your pages.  Contrast can be accomplished through colors or other methods, such 
as type style.  Look at the examples below to see some ways of using contrast. 

 
Color Contrast 

USCG United States Coast Guard 
Training Center Petaluma 

Example 3 - USCG stands out from the rest of the text because of the black background and white text 

Typographical Contrast 

USCG United States Coast Guard 
Training Center Petaluma 

Example 4 - Here the words United States Coast Guard have been made all caps and larger, setting them apart 
from the next line.  The contrast in typeface gives United States Coast Guard more importance 

 
 

Combining Design Principles 
These four design principles should never be used in isolation, you should use them together.  The 
more you can remember and use these principles, the better your pages will become. 

Page Layouts 
When working on the visual design of your pages you should develop different layouts for 
different types of pages.  For example your section index pages should look slightly different from 
the home page and the pages in the section.  You can create several layouts that will serve as 
templates for your web site.  Once you create the templates, creating new pages is just a matter of 
inserting content into the template.  The layouts should be similar to maintain consistency. 

 

Design Document 
As you develop the design of your site you write everything down.  All your design specifications 
from information design, interaction design, and visual design form a design document.  When 
you actually start developing the site this document is your blue print for the site.  

Earlier, during the information design phase, we used the analogy that a blue print for a house will 
show where the bathrooms are located.  Blue prints for a house include much more information 
than just where each room is located.  Continuing with the bathrooms, the blue print also tells you 
how the plumbing and electrical are connected.  It also specifies the size of the bathroom and how 
it is framed into the rest of the house and where the door should be.  Blue prints provide a detailed 
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map of how the house will be built and how the bathrooms fit into the larger structure.  Your 
design document should do the same thing for your web site. 

It may seem like a lot of trouble to write everything down, but it is well worth the time. Most of 
the work on a web site is in the design.  You must have a solid plan before you start creating pages.  

Design Tips and Hints 
Here is a list of things to consider while design our site 

♦ Times New Roman and Garamond are easy to read fonts. 

♦ Serif fonts (such as Times New Roman) are easier to read and should be used for 
extended sections of text. 

♦ Sans Serif fonts (such as Arial) are more legible and are recognized easier in short 
headings. 

♦ Use Serif fonts as your body and use Sans Serif as headings (For example Arial 
headings, Times New Roman text). 

♦ Avoid using fancy fonts, not every computer has the same fonts.  Stick with basic 
fonts. 

♦ Fancy fonts are harder to read. 
♦ Don't use the default background color, at least set it to white. 

♦ Don't use the default font.  People can change the default font, so you should specify 
your fonts. 

♦ Text should be between 10 and 14 point. 
♦ Use shorter lines of text.  They are easier to read. 
♦ Maintain sufficient contrast between the background and text. 
♦ Don't use all caps unless you have to. 
♦ Navigation buttons should be easily understood. 
♦ Don't use borders on images, they should be framed by other elements on the page. 

♦ Your home page should not need any scrolling.  On the Internet, design the 
homepage for a 640x480 screen. 

♦ Use Alternate labels for images. 
♦ Spell Check. 
♦ Don't abuse animated GIFS. 
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Introduction to FrontPage 
Once you have a plan for your site, it is time to start creating pages.  FrontPage 98 makes the 
creation and management of web pages much easier than writing all your pages in html. 

FrontPage actually includes several programs.  The two main programs are FrontPage Explorer 
and FrontPage Editor.  FrontPage Explorer is used to manage your site while Editor is used to 
create and edit web pages.  FrontPage also comes with Microsoft Image Composer for editing 
graphics.  We won't be using Image Composer in this workshop. 

FrontPage Webs 
FrontPage doesn't really deal with individual web pages, rather it deals with web sites.  When you 
use FrontPage you will open an entire site.  Individual pages can be edited, but only after opening 
the site in FrontPage Explorer first. 

There are a lot of reasons for this, most of which will become clearer as we work through the 
exercises.  But the main reason is that it allows you to actually manage sites as a whole.  There are a 
lot of functions of FrontPage that apply to the whole site.  All of these functions are managed 
behind the scenes by FrontPage as you work.  As you create your site, you will use many of these 
functions.  For now it is important to start thinking of your site as a single entity made of many 
pages.  That is how FrontPage thinks of sites.   

Web Site Design 
To make your life a little easier, the design of your practice site has already been determined.  
Below is a screen shot of how the web site will look when we are done. 

Section 

3 
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This page includes the design specifications: 
♦ Background image to create the left border. 
♦ Required Coast Guard elements for Internet pages at the top and bottom of the page. 
♦ Links to section heading in the left border, except on home page. 

♦ The title of the page directly below the CG banner.  The text is Arial font and a 
heading 2. 

♦ Text of the page in Times New Roman font. 
♦ Links at the bottom of the page are 12 pt Arial font 
♦ Page uses tables to establish layout. 
♦ All pages use the same layout. 

 

As we go through the exercises we will be creating pages that follow these design guidelines. 
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Creating a Web Site 
Getting Started 
Creating web sites is often a process of trial and error where you experiment with your pages until 
they are perfect.  Then you find some other way to refine them.  The following exercises will walk 
you through a more streamlined, step-by-step process of creating a web site.  

For many exercises you will need to look in the book for step by step instructions.  Some exercises 
will give you step by step instructions when there are specific outcomes required or the book 
doesn’t cover the material. When step by step instructions are given, references to the FrontPage 
98 Unleashed book are given in gray boxes to the left of the exercise.  Even when step by step 
instructions are given with the exercise you should read the related pages as they may contain other 
important information. 

Creating a New Web 
In order to create web pages in FrontPage you must first create a web.  For this class you will be 
creating a web in the instructor's public folder.  To create a web, follow these instructions: 

1. Open FrontPage.  The Getting Started window will appear. If it does not, go to the 
File menu and select New and trace to FrontPage Web. 

2. Click Create a New FrontPage Web. 
3. Click OK. The New FrontPage Web window will open. 
4. In the list of templates click Empty Web. 
5. Click the Change button. 
6. Enter the path to your web. Your web will be saved on your G:\ drive.  Use the path 

given below, but insert your user name in place of username. 
7. G:\ghegenbart\public\fpwrkshp\username 
8. Click OK. 
9. Enter your username as the title for the web.  
10. Click OK. 

Your web will be created and FrontPage Explorer will open to the Navigation view. 

Importing Files 
Now that you have a web, you need to add web pages.  You can create web pages using FrontPage 
Editor, but if you already have pages created you will want to import them into FrontPage.  For 
the exercises, the basic pages have been created. You just need to import them into FrontPage. To 
import files follow these steps: 

1. From the File menu choose Import.  The Import File to FrontPage Web window 
will open. 

2. Click Add File.  The Add File to Import List window will open. 
3. In the Look in field select G:\. 

FrontPage 98 
Unleashed  
Pages 25-26 

FrontPage 98 
Unleashed  
Pages 29-30 
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4. Open Ghegenbart. 
5. Open Public. 
6. Open fpwrkshp. 
7. Open Files. 
8. Click the first file.   
9. Press Ctrl + A to select all the files. 
10. Click Open.  The files will be added to you import list. 
11. Click OK.  

The files will be imported to your web. 

Managing Files 
All the files you will need for the exercises were imported into your web, but they are not 
organized.  You will need to create some folders and move files to better organize the pages in 
your web.  First we’ll create the folders then move the files. 

Creating Folders 
1. Change the view in FrontPage Explorer to Folders. 
2. From the File menu, trace to New and select Folder.  A new folder will be created. 
3. Name the folder cutters. 

Repeat these steps to create folders named boats and aircraft. 

Moving Files 
1. To move files you simply click and drag the file to the desired folder.  Y ou can drag 

files into folders in either the left or right pane of the window. 
2. Move all the image files to the images folder. 
3. Move the following files to the cutters folder: 

♦ 175wlm.htm 
♦ 378ctr.htm 
♦ icepolr.htm 
♦ 180wlb.htm 

4. Move the following files to the aircraft folder: 
♦ hc-130.htm 
♦ hh-60.htm 
♦ hh-65.htm 
♦ hu-25.htm 

5. Move the following files to the boats folder: 
♦ rhi.htm 

FrontPage 98 
Unleashed  
Ch. 46 

Tip 

You can hold 
down the Ctrl 
key while 
clicking to select 
multiple files. 
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♦ psuboat.htm 
♦ 47msb.htm 
♦ mlb-44.htm 
♦ 41utb.htm 

You should now have all your files organized. 

Navigation 
The navigation view allows you to establish how pages in your web site are related to each other in 
a hierarchical diagram.   The navigation view can also be used to create navigation bars on web 
pages that are based on the hierarchical structure of the web.  Navigation bars will be covered in a 
later section.  The index.htm page should always be at the top level.  In our web, index.htm is the 
only page at the top level, but you can have other pages at the top level. Read pages 790-793 and 
complete the following exercise. 

Exercise 
1. Use the navigation view to create the hierarchy as shown below. When asked if you 

would like FrontPage to create navigation bars, click No. 

2. Now go into each folder and add the pages under their respective parent page.  For 
example all the pages in the cutter folder would be under the Cutters page.  When you 
are done, your navigation view should look similar to the example below. 

FrontPage 98-
Unleashed  
Ch. 46 

Tip 

In the View  
menu select 
Size to Fit to 
see the entire 
navigation 
structure. 
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Editing Pages 
Up to this point you have been working on your web site, but you haven’t worked on any pages.  
It is now time to open up pages and use the FrontPage Editor to modify them.  We’ll start with 
some basics using index.htm as the example. 

In either Folders view or Navigation view double-click index.htm to open it.  FrontPage Editor 
will open. 

Page Properties 
Before you begin making changes to the page, you need to set the properties of the page.  
Properties include things like background, default font colors, and other things.  Read Setting Page 
Properties on pages 54-66 and then set the following properties: 

♦ Background color - White 
♦ Default text color - Black 
♦ Hyperlink color - Navy 
♦ Visited link - Maroon 
♦ Active link - Blue 
♦ Leave the rest of the settings at the default value 

Formatting Text 
FrontPage allows you to easily change the appearance of text just as you would in Microsoft Word.  
Once you have read the pages referenced in the book, make the following changes to the page: 

1. Set page heading as a Heading 2 – Pages 67-68 
2. Format the words Cutters, Aircraft, Boats and History as a bullet list – Page 80-88 
3. Make the list Bold and change font of list to Arial  – Pages 94-97, 98-100 

Creating Hyperlinks 
At the heart of any web site is the links between the pages and to pages outside the web site.  
FrontPage makes it easy to create and edit links.  Read pages 72-78 then create the following 
hyperlinks: 

1. Using the words in the list, create links to the corresponding pages.  For example, use 
the Cutters as a link to the page Cutters. 

Inserting Images 
Not only does FrontPage make it easy to insert images, but it also has many image editing 
capabilities built in.  In addition, FrontPage comes with Microsoft Image Composer, a full-
featured image editing program.  Chapter 7 (starting on page 107) covers working with images in 
FrontPage and Chapter 16 (starting on page 273) covers Image Composer.   

For this exercise we will only insert an image into our page. More advance image topics will be 
covered later. 
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Exercise 
1. After reading pages 109-112, open 41utb.htm and insert the image file 41ft.gif. 

Practice Exercises 
Now that you’ve had a chance to see some of FrontPage, it’s time to practice what you have 
learned.  To this point we have only worked on the index.htm page and haven’t made any changes 
to the other pages.  To practice what you’ve learned so far make the following changes: 

1. On every page set the following page properties: 
♦ Background color - White 
♦ Default text color - Black 
♦ Hyperlink color - Navy 
♦ Visited link - Maroon 
♦ Active link - Blue 

2. Insert the following images into the pages noted: 

Image Folder/file 

44mlb.jpeg boats/mlb-44.htm 

47mlb.gif boats/47msb.htm 

B75.jpeg boats/rhi.htm 

hc130.gif aircraft/hc-130.htm 

hh60.gif aircraft/hh-60.htm 

hh65a.gif aircraft/hh-65.htm 

hu25.gif aircraft/hu25.htm 

psu.jpeg boats/psuboat.htm 

whec.gif cutters/378ctr.htm 

wlb.gif cutters/180wlb.htm 

wlm.gif cutters/175wlm.htm 

icebreaker.gif cutters/icepolr.htm 

We will not be inserting any hyperlinks at this time.  That will be done in the next section. 

Shared Borders 
Shared borders allow you to easily include repeated content on every page.  This feature is 
designed so that you can put common page headers, footers, left borders, or right borders on 
every page in your web.  For Coast Guard pages this feature is useful for adding the required 
elements to pages.  Initially when you create shared borders they are included on every page, but 
you can turn them off on individual pages. 
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Turning on Shared Borders 
We will use the shared borders to put the required Coast Guard elements on every page.  Turn on 
shared borders by following these steps: 

1. Go to FrontPage Explorer. 
2. From the Tools menu select Shared Borders. 
3. In the window that appears, check the boxes next to Top and Bottom. 
4. Click OK. 

The shared borders will be applied to every page in your web. 

Editing Shared Borders 
To edit shared borders you must open a page in FrontPage Editor.  Follow these steps to modify 
the shared borders. 

1. Open index.htm in FrontPage editor.  You will see the shared border at the top and 
bottom of the page.  A dashed black line shows where the borders end and start. The 
page banner and some navigation buttons will automatically be placed in the top 
border.  A comment will be placed in the bottom border. 

2. Delete the navigation button in the top border. 
3. Align the title to the left. 
4. Format the page banner so that it is a heading 2 and Arial font. 
5. Before the title insert the image rcstripe.gif. 
6. In the bottom border delete the comment. 
7. Insert the image cgsmbar.gif 
8. Insert a line break and enter the following text with 10 pt Arial font: 

[ USCG Home Page ] 
[ Email ] 
Last Updated:  

9. Using the text you just typed create links to the USCG home page and your email 
address. 

Timestamp 
Timestamps automatically insert a date onto your page.  Follow these steps to insert the date the 
page was last updated in your bottom border. 

1. In the bottom border place the cursor after Last Updated: . 
2. From the Insert menu select Timestamp. 
3. In the window that appears select Date page was last updated. 
4. Choose a date format and leave the time format at None. 
5. Click OK.  The date will be inserted. 
6. Save the page. 

 

The changes you just made will now appear on every page in your web. 

Tip 

The Page 
Banner is a 
FrontPage 
Component. 
For more info 
see Ch. 24 

Tip 

To insert a 
line break 
press 
Ctrl+Enter. 
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Tables 
One of the most powerful features of FrontPage is the ability to easily create and manipulate tables 
on web pages.  Our page layout requires that we set up tables in the web pages and the borders.  
We could not have used a left border because borders do not allow you specify the size of the 
border. Read Chapter 8 and then complete the following exercise. 

1. Open index.htm. 
2. In the body of the page create a table with the following specifications: 

♦ One row and three columns  
♦ Fixed table width of 700 pixels 
♦ No border 
♦ Cell spacing and padding of 2 

3. Move all the text and images on the page (excluding the borders) into the third 
column of the table. 

4. Set the width of the first cell to 15 pixels and the vertical alignment to Top. 
5. Set the width of the second cell to 120 pixels and the vertical alignment to Top 
3. In the top border, create a table with the following specifications: 

♦ One row and two columns  
♦ Fixed table width of 700 pixels 
♦ No border 
♦ Cell spacing and padding of 2 

6. Set the width of the first cell to 135 pixels and the vertical alignment to Top. 
7. Repeat these steps with both the top border. 
8. Delete any extra line breaks or paragraphs. 
9. Set the page background to the image stripe.gif. 

When you are done you should see everything in the page contained in tables. Preview the page in 
Internet Explorer to verify your changes were made. 

Practice Exercise 
Make the following changes to the rest of the pages in the web site: 

1. Make sure the shared borders are set to web default.  
2. Create a table in the body of the page as done in the previous exercise and move the 

text of the page into the table. 
3. Preview your pages in Internet Explorer. 
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Navigation Bars 
Your web site already has a structure and navigation set up.  FrontPage will automatically create 
links to pages based on the navigation scheme we set up earlier. Navigation bars are FrontPage 
components that translate the navigation scheme into hyperlinks.  Navigation bars are specifically 
designed for use with FrontPage themes, but they can be used in pages that do not use a theme.   

When using navigation bars you have little choice in how the navigation bar is displayed.  In pages 
that do not use themes you must use text for the links.  The text that will be used as the link is the 
page title as shown in Navigation View.  Read pages 794-798 and then complete the following 
exercise. 

1. Open index.htm in FrontPage Editor if it is not already open. 
2. In the bottom border insert a line break before the USCG Home Page link. 
3. In the line before USCG Home Page, insert a navigation bar with the following 

properties: 
♦ Navigation only to the top level 
♦ Orientation set to Horizontal 
♦ Appearance set to Text 

4. Open cutters.htm. 
5. In the body of the web page click in the first column of the table. 
6. Insert a navigation bar with the following properties: 

♦ Navigation only to the Same level 
♦ Orientation set to Vertical 
♦ Appearance set to Text 

7. Click the navigation bar. 
8. Change the font to 10 pt Arial bold. 
9. Repeat for aircraft.htm, boats.htm, history, and history.htm. 
10. Save all pages and preview them in Internet Explorer. 

 

Practice 
1. In cutter.htm, boats.htm, history, and aircraft.htm insert a navigation bar with the 

following properties: 
♦ Navigation only to the Child level 
♦ Orientation set to Vertical 
♦ Appearance set to Text 
♦ Font formatted as 10 pt Arial bold 

2. For all the pages in the cutters, boats, and aircraft folders insert a navigation bar with 
the following properties in the first column of the body: 

Tip 

You can use the 
HTML view to add 
a line break if you 
can’t in Normal 
view. 
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♦ Navigation only to the Same level 
♦ Orientation set to Vertical 
♦ Appearance set to Text 
♦ Font formatted as 10 pt Arial bold 

Style Sheets 
Formatting text in FrontPage is relatively easy, but still time consuming.  For every text element 
you want to be bold you have to select the text and use the bold command.  Style sheets offer a 
quick way of formatting elements in your web pages by defining the style once and applying it 
throughout a page or site.  For example if you want all text that is H1 to be 16 pt, bold, Arial font 
you can include that in a style sheet and the formatting is applied to all H1 text. 

Style sheets make it easy to apply formatting throughout your web site.  This will help ensure that 
all your pages will have a consistent look and feel. 

There are actually three different types of style sheets- in line styles, header-defined styles, and 
external styles.  FrontPage makes it easy to define the in line and header- defined styles, but has no 
way of defining external styles.  External styles are stored in a text file and are referenced in the 
Head section of a page.  You can use external style sheets, it is just a little more work. 

Even when you use a style sheet, you can override the style specifications by applying formatting 
to text.  For example if a style sheet defines H3 as 10 pt, bold, Times New Roman you can 
override the style specification by applying a different font to any H3.  Browsers will use the text 
formatting and ignore the style sheet.  This is important because if you apply a style sheet after you 
have formatted some text, the style sheet will be ignored. 

Header Defined Styles 
In this exercise we will create a header-defined style sheet in FrontPage.  Before you begin you 
need to read chapter 11 starting on page 185 to get more information on how FrontPage supports 
style sheets. 

Exercise 
1. Open index.htm in FrontPage Editor, if it is not already open. 
2. From the Format menu choose Stylesheet. The Stylesheet window will open. 
3. Place the cursor just after the <!-- 
4. Press the Enter key to insert a blank line. 
5. Type h2. 
6. Click the Style button.  The Style window will appear. 
7. In the Alignment tab set the left margin to 10. 
8. Click the Font tab. 

Tip 

For a list of 
style elements 
see page 192. 
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9. Set the font to Arial Black with a size of  16 pt. 
10. Click the Colors tab.   
11. Set the Foreground color to Blue. 
12. Click the Text tab. 
13. Set the Letter Spacing to 3px. 
14. Click OK.  The styles will be inserted into the style sheet. 
15. Click OK.  The style will be applied to the page. 
16. Save the page and preview it in Internet Explorer 

External Style Sheets 
While header-defined style sheets are great, you still have to create them for every page.  If you are 
going to use the same style sheet on every page you can create one style sheet and just reference it 
in your pages.  The only real trick to style sheets is using the proper syntax.  To ensure we use 
proper syntax we will use a header-defined style sheet to create an external style sheet. 

In this exercise we will create a header-defined style sheet then copy it into a text document in 
Notepad.  This will be saved and used as an external style sheet.  We will then delete the header 
defined style sheet. 

Exercise- Header-Defined Styles 
1. Open index.htm in FrontPage Editor, if it is not already open. 
2. From the Format menu choose Stylesheet. The Stylesheet window will open 

showing the styles defined in the previous exercise. 
3. Place the cursor just before the - - > 
4. Press the Enter key. A blank line will be inserted into the style sheet. 
5. In the blank line type p.  This will format text in paragraphs. 
6. Click the Style button. 
7. Add the following styles: 12pt, Arial, color - black. 
8. Insert another blank line and type li.  This will format line items 
9. Add the following styles: 14pt, Arial, bold, color - green. 
10. Click OK. 
11. Click OK to close the Stylesheet window. 
12. Switch to HTML view. 
13. In HTML view locate the style sheet in the head section. 
14. Highlight and copy the following text: 

h2{ font-family: Arial Black; font-size: 16 pt; color: rgb(0,0,255); letter-spacing: 3px; 
margin-left: 10 } 
p{ font-family: Arial; font-size: 12pt; color: rgb(0,0,0) } 
li{ font-family: Arial; font-size: 14pt: color: rgb(0,128,0)} 
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15. Open Notepad. 
16. Paste the text. 
17. Save the file as style.css into your FrontPage web folder.  This will be on you G:\  

drive – G:\ghegenbart\public\fpwrkshp\username 
18. Return to FrontPage Editor. 
19. In HTML view locate the style sheet in the header.  This starts with the <style> tag.   
20. Delete the style sheet from the header.  The style sheet is between the <style> and 

</style> tags.  Be sure to delete the style tags as well. 
21. Save the page. 

 

Exercise- External Style Sheets 
Now that we have created an external style sheet, it needs to be linked to every page in your web.  
Follow these steps to link the style sheet to a web page.   

1. You should have index.htm open in FrontPage Editor.  If not, open it. 
2. Go to HTML view. 
3. Place the cursor before the </head> tag and press enter to create a blank line. 
4. In the blank line before the </head> tag type the follow tag: 

 <link rel="stylesheet" HREF="style.css"> 
NOTE: The style.css file must be in the root folder of your web. 

5. Save the page. 
6. Preview the page in Internet Explorer.  The styles in the style sheet should be applied 

to your page. 
 

Practice Exercise 
Repeat the above exercise for every page in your web. 

 

For information on advanced uses of  Style Sheets see chapters 11 and 12 of FrontPage 98 
Unleashed.
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Graphics Basics 

Types of Images 
Computer generated images come in two forms, bitmaps and vector based graphics.   

A bitmap is created by coloring individual pixels in an image which are then displayed (or 
mapped) onto the screen.  With bitmaps, each pixels in a bitmap image is assigned a color value.  
When you view a bitmap image all the pixels appear to run together.  However, if you zoom into a 
bitmap you can actually see the different pixels.  The examples below show an example of this. 

 

Example 5-Bitmap image viewed normally  

 

Example 6 - Zoomed in image shows pixels  

Some common bitmap file formats include GIF, JPEG, BMP, PICT, and TIFF.  These file can be 
read by most image editing programs. 

A vector graphic is created based on mathematical definitions in the file, which are computed to 
display the image.  Vector graphics do not assign color values to pixels, rather they essentially tell 
the computer how to draw an image.  When you zoom in on a vector graphic, you won't see pixels 
because the image is re-drawn. 

Web File Formats 
Web pages deal entirely with bitmap images that are either GIF or JPEG format.  Each type of 
image offers different advantages and disadvantages.  For more information see the Introduction 
to HTML web site at http://cgweb.tcpet.uscg.mil/ltc/htmlcourse  

 

Section 

4 
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Bit depth- 
One thing that greatly impacts the file size of a bitmap image is the bit depth.  The bit depth 
determines how many colors are in the image. The more bits an image has, the larger the file size.  
Below is a listing of various bit depths and their corresponding number of colors. 

32 bit - Millions of colors + Alpha channel, or CYMK 

24 bit - Millions of colors, RGB, 8 bits each 

16 bit - Thousands 

8 bit - 256 colors or grayscale 

4 bit - 16 colors or grayscale 

2 bit - 8 colors or grayscale 

1 bit- 2 colors, black and white 
 

When using images in web pages file size is one of your major concerns.  The larger the file, the 
longer the download time.  If you can reduce the number of colors in an image, you can reduce 
the file size.  This is what a GIF does.  GIF images can only have 256 colors, so their file size is 
much smaller than a 24 bit file.  JPEG can have 24 bit color and accomplishes smaller file size 
through compression. 

While 256 colors may not sound like a lot, it can usually be sufficient.  In general unless your image 
is a photograph or has a lot of subtle color gradients 256 colors will be more than enough.  That is 
why GIFs are better for graphics such as buttons, logos, illustration, and line art. 

Indexed Color and Color Palettes  
On great advantage to 8 bit images is that you can pick the 256 colors in the image.  Say for 
example your image has a lot of blue shades.  You can create a color palette that contains mostly 
blue.  This is often referred to as indexed color.   

Browser Safe Colors 
Not all browsers and computers can display the same colors.  Different browsers and operating 
systems use slightly different color palettes.  As a result your images may not display properly on all 
computers.  If you want to make sure your images will be properly displayed, you will need to use 
what is know as a browser-safe palette.  This palette contains the most common 216 color used by 
all browsers.  On page 288 of The Non-Designers Web Book there is a chart of these colors along 
with their hexadecimal codes and RGB values. 

Microsoft Image Composer has a browser safe palette available, but Micrografx does not.
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Micrografx Picture Publisher 
Micrografx Picture Publisher is a bitmap editing program.  To open Picture Publisher click 
the Start menu, trace to Programs, trace to Micrografx and select ABC Picture 
Publisher. 

Picture Publisher Overview 
The overview of Picture Publisher is given as a demonstration by the instructor.  If you 
would like more information on Picture Publisher see Help.  Picture Publisher has a good 
help system that gives a complete overview of the application including step-by-step how to 
directions for specific task. 

Help topics you should review are: 

♦ Getting Started 
♦ Working with Tools 
♦ Working with Masks 
♦ Working with Objects 

Resizing Images 
To resize an image you need to open the Size Image window.  From the Image menu 
choose Size. The Size Image window is shown on the next page will open.  The Size 
Image window allows you to resize, scale, and change the resolution of an image.  At the 
bottom of the window are boxes that allow you to set sizing options.  By default images are 
proportionally sized.  You can allow size distortions by checking the Allow Size 
Distortions box.  In most cases you will not need any of the boxes at the bottom of the 
window checked.   

Section  

5 



 

 2626 

 

Exercise 
To complete this exercise you will need to open the file P0000289.JPG.  Follow these steps 
to open and size this image. 

1. Click the Open button.  The Image Browser window will open.  
2. Click the View Files button.  The window will change to the Open window. 
3. In the Look in field select U:\ 

4. Located and double click the Web Workshop folder. 
5. In the Files of Type field select All Supported Files. 
6. Locate and open the file P0000289.jpg.. 
7. From the Image menu choose Size.  The Size Image window will open. 
8. Change the resolution to 72. 
9. Change the width to 500. 
10. Click the Size button.  The image will be resized. 

Cropping 
Cropping allows you to cut out portions of the picture that you don't need.  Since bitmaps 
can only be squares, the crop tool can only select rectangular areas.  To crop an image select 
the crop tool from the Mask Tools and then click and drag a selection.  As soon as you 
release the mouse button the image will be cropped. 

An alternate and more effective way to crop is to create a mask and then crop to the mask.  
To do this use the rectangular mask tool to create a mask over the area of the picture you 
wish to keep.  From the Mask menu choose Crop to Mask.  The image will be cropped to 
the mask.  If your mask was not a rectangle, Picture Publisher will crop to a rectangle based 
on the farthest edges of the mask.  To illustrate this use the circular mask tool to create a 
mask then crop to the mask. 
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Exercise 
1. From the Mask Tools select rectangle and elliptical mask tool. 
2. Position the cursor above and to the left of the building. 
3. Click and drag to the lower right corner of building to create a mask. 
4. From the Mask menu choose Crop to Mask.  The image will be cropped to 

your mask. 
 

Adding Text 
When text is added to an image it is automatically added as a separate object.  This allows 
you to move or change the text after it has been created.  If you have applied any effect to 
text then try to edit the text you will get a message warning you that the effect's changes will 
be lost.   

To add text to an image, first select the color you want the text to be.  Then select the text 
tool.  Set the font, size, and style on the ribbon.  Then click in the image where you want 
the text to be located.  An text insertion point will be created allowing you to type the text. 

Exercise 
1. Change the active color to Red. 
2. Click the text tool 
3. Change the font to Arial Black, 26 pt. 
4. Click in the image where you want the text to be located.  An insertion point 

will appear. 
5. Type Bauer Building. 
6. Click the selection tool.  The text object will be created. 

Saving Files 
When you save a Picture Publisher file as a bitmap such as BMP or GIF all objects are 
automatically combined with the base.  However, you can save as a Picture Publisher file 
and all objects will be maintained.  The Picture Publisher format is .ppf.  

Picture Publisher is not without it faults.  One fault is that every time save you a .ppf file, 
you get the following error-   
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This is normal and does not mean the file was not saved.  In fact, your file will be saved.   

Also, if you close a file then reopen it, and try to save it you might get the following message 
in addition to the one above- 

 

Again, the file is really saved, but you still get an error.   

One way to avoid these errors is to save the file under a different name every time you save.  
Although this is somewhat laborious, you avoid the errors and ensure your file is saved. 

One last little bug.  When you close a PPF file Picture Publisher will a sk you if you want to 
save changes.  If you click Yes, the file will be saved and you will get the first error 
mentioned above.  The file won't close.  When you try to close it again, Picture Publisher 
will again ask you if you want to save changes.  This loop goes on forever.  The only way 
out is to make sure the file is saved and click No the second time you are asked if you want 
to save changes. 

Exercise -Saving a file 
Now that you know all the problems with saving files, it's time to actually try it.  The steps 
below should work, but since the program is somewhat buggy your experience may be 
slightly different. 

1. From the File menu choose Save As.  The Save As window will open. 
2. Check to make sure you are saving to your Web Workshop folder.  If not use 

the Save in box to move to your Web Workshop folder. 
3. From the Save as type pop up menu choose Micrografx Picture Publisher 

(*.ppf) 
4. Enter bauer as the file name. 
5. Click Save.   

The file will be saved as a Picture Publisher file maintaining all objects. 

If you didn't get any error messages when you saved the file, you will the next time you save 
the file. 
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Creating a Montage 
A montage is simply a collection of images combined into one.  The image on the home 
page for sample Data Sheets site is a simple montage of four images with text.  The 
following exercise walks you through the steps necessary to create this same montage.  The 
functions you will be using in Picture Publisher include: 

♦ Creating a mask 
♦ Copying and pasting  
♦ Adding text 
♦ Feathering a mask 
♦ Cropping 

♦ Saving 

Starting a New Image 
The first thing you will need to do is create a new document and open the four images that 
make up the montage. 

Exercise - Creating a New Image 
1. From the File menu choose New.  The New Image window will open as 

shown below. 

2. Set the following options 
Image Type - RGB Color 
Width - 500 pixels 
Height - 500 pixels 
Resolution - 72 ppi 

3. Click the Create button.  A new image will be created. 
4. Save the file as Montage.ppf. 
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Exercise Opening Files 
1. From the File menu choose Open. The Open will open. 
2. In the Look in box select U:\. 
3. Open the folder Web Workshop. 
4. Open the folder Raw Images. 
5. Locate and open the file whec.gif. 
6. Repeat steps 1-4 to open the following files: 

41ft.gif 
hh60.gif 
eagle04.jpeg 

You should now have the four files open that will make up the montage. 

Copying Images 
To copy images in Picture Publisher you must use the mask tool.  To copy part of an image 
you simply create a mask and then use the copy command to place the masked part of the 
image on the clipboard.  You can then paste the image into another document.   

In the sample montage all the images are the same size, so when you copy them you need 
to make sure the mask is the same size every time.  The easiest way to do this is to use the 
Rectangular Mask tool to specify an exact size.  This will create a mask that is always the 
same size.   

You may have noticed the image eagle04.jpeg is quite a bit larger than the other images, 
but in the montage all the images need to be the same size.  The hh60.gif image is the 
smallest image a t 106 pixels wide by 72 pixels high so we will set the mask to be the size of 
that image.  But first the Eagle04.jpeg image needs to be reduced and all the images need to 
set to 72 ppi. 

Practice - Scaling an Image 
1. Make eagle04.jpeg is the active document. 
2. Resize the image so that it is 106 pixels wide and is 72 ppi.  The eagle04.jpeg 

image should now be resized. 
3. Resize all the images so that they are 72 ppi.  Do not adjust the height or width. 

Using the Mask Tool 
Since we know the hh60.gif image is 106x72 pixels we can specify the rectangular mask 
tool to create a mask that exact size.  If we use the same size mask to select and copy each 
image the four images in the montage will be the same size. 

Exercise - Copying Images 
1. Make whec.gif the active window. 
2. Select the Rectangular Mask tool. 
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3. In the Tool Ribbon (shown below) set the Method to Constrain Size. 

 
4. Set the size to 106 pixels wide and 72 pixels high. 
5. Place the cursor in the middle of the image and click once.  A mask will be 

created. 
6. Copy the selection. 
7. From the Window menu choose the Montage file. 
8. Paste the image.  The image will be pasted as an object. 
9. Click and drag the image to the desired position. 
10. Press the Enter Key. 
11. Repeat steps 5-10 for 41ft.gif, eagle04.jpeg, and hh60.gif.  
12. Arrange the images so that they form a square montage as shown below.  

13. Save the file. 
When you are done you should have all four images in your Montage file. 

Feathering 
Right now the square montage has a hard edge.  Feathering softens edge so that it blends 
with the background.  Feathering can be applied to either and object or a mask.  Right now 
the montage is four different objects positioned together.  Before feathering is applied the 
objects need to be combined. 

Exercise - Feathering 
1. Select the whec object. 
2. Hold down the Shift key and click the other three objects to select them all. 
3. From the Object menu trace to Combine then select Objects together.  The 

object will be combined. 
4. From the Object menu choose Feather Object.  The Feather Object 

window will open as shown below.  
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5. Set the Amount to 4 and the Edge to Normal. 
6. Click the Feather button.  The Object will be feathered. 
7. Save the file. 

Practice -  
1. Add the following text over the appropriate image: 

♦ Cutters 
♦ Boats 
♦ Aircraft 
♦ History 

2. Crop the image so that there is almost no white space around the image. 
3. Save the file. 

Saving  
The montage is now complete and needs to be saved as a JPEG file.  Remember, when 
saving as a JPEG all objects will be combined with the base.  If you want to make changes 
to the file at a later time, you can always open the PPF file. 

Exercise 
1. From the File menu choose Save as.  The Save as window will open 
2. In the Save as type box select JPEG File Interchange (*.jpg). 
3. In the Save in box select U:\. 
4. Locate and open the folder Web Workshop. 
5. Click the Save button. 

The file will be saved as a JPEG file. 

Practice 
1. Open your web in FrontPage and import the montage.jpg file. 
2. Add the montage.jpg file to the index.htm page 



 

 3333 

Transparent GIF Files 
GIF files have the ability to have a color be transparent so that the background will show 
through.  GIFs are bitmap images so they have to be rectangles.  But what if you want to 
include a graphic that is not a square?  The only way is to make the background color 
transparent.  This feature is a  great way to make graphics that are not rectangular display 
properly on a web page.  In the example below the Training Center logo is shown with 
transparency and without. 

  

Example 7 - The image on the left has a transparent background while the image on the right does not.   

Picture Publisher can save files a GIF files, but it cannot create GIFs with transparent 
colors.  Fortunately FrontPage can.  So creating a transparent GIF is a two step process.  
Step one you must create the GIF in Picture Publisher and step two you have to make it 
transparent in FrontPage. 

One thing you have to be sure to remember is that transparent 
GIFs can't tell the difference between the background and the 
image.  They only make a single color transparent.  You also have 
to be sure that the transparent color is not included in the 
graphics.  Take a look at the example on the right.  The 
background is white, but the graphic also includes white.  In this 
case you would fill the area around the graphic with another 
color that is not used the image and make it transparent. 

In the next exercise you will be making a transparent GIF using 
the image shown in Example 10.  To do this you will be using 
the Smart Mask tool to select the background and then filling 
with a different color. 

Exercise -  Setting the Background 
1. Open Picture Publisher if it is not already open 
2. From the File menu choose Open. 
3. In the Look in box select U:\. 
4. Locate and open the Web Workshop folder. 
5. Locate and open the Raw Images folder. 
6. In the File of type field select All Supported Formats. 
7. Locate and open cglogo1.gif.  The image shown in Example 10 will open. 
8. Select the Smart Mask tool. 

 
Example 8 - The 
background and graphic 
both contain white, so 
which cannot be 
tranparent. 
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9. Set the Wand Range to 5%. 
10.  Using the Smart Mask tool, select the background of the image 

NOTE:  Because the background is not a uniform color the entire 
background will not be selected.  You will need to click in any areas of the 
background that were not selected to select them. 

11. Once the entire background is selected, change the active color to Purple . 
12. Using the Fill tool, fill the selected area with purple. 
13. Save the file. 
14. Close Picture Publisher. 

Exercise - Make Transparent in FrontPage 
1. Open your FrontPage web. 
2. Import the cglogo1.gif into your web. 
3. Open index.htm 
4. Insert cglogo1.gif into the first cell in the top border. 
5. Select the image.  The drawing toolbar will open. 
6. Select the Make Transparent tool.  
7. Click anywhere in the purple area of the cglogo1.gif file.  The background will 

become transparent. 
8.  Save the page.  When you save the page the following window will open: 

9. Click OK.  This will replace the original image with the new transparent one. 
10. Preview the page in the Internet Explorer. 
 

Because the cglogo1.gif file is in the top border it will appear on all your pages. 
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Creating Frames 
Creating Frames will allow you to create web pages that have multiple independent regions, 
somewhat like and independent window. Each page is somewhat like a mini- Web Browser. 
They can have scroll bars, size manipulators and borders, even headers and footers. It is 
important to remember a few important issues when creating frames. 

Targeting 
Be careful about what types of web pages you link to from framed pages. A link on your 
framed page may take the viewer to another framed page. That page may in turn, take the 
viewer to another framed page. Eventually the person viewing the site is framed into a 
corner and is left to view information in a two-inch square on the screen. The person will 
get annoyed and probably leave your site. For this reason along with setting up frames, 
Targeting is equally as important as the frame setup itself.  

Think carefully about the pages you are going to set up as frames. It is possible to overdo it. 
Ask yourself the following questions: Will framing enhance the navigation of this site? Are 
there links to other framed pages on my site? Are there links to framed pages on other web 
sites? 

Working with Frames 
The best thing about frames is that it allows the developer to create pages that are not 
limited to one simple top-down page.  

We refer to the common window for frames as the Frame Source Page.  This page defines 
the size and attributes of each frame. It also specifies the web page that occupies each 
frame. Thus creating the page shown in the example below, requires a total of 4 HTML 
pages: 

♦ A frames source page 
♦ Three HTML Pages, one for each frame. 
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Exercise – Create a new  a new frames page using a template. 
It is possible to create frames from scratch. FrontPage has a variety of preset frame 
templates using the most common settings.  

1. In the FrontPage Editor, open Aircraft.htm. 
2. On the Frame Menu, select New Frames Page. A dialogue box of choices 

will appear. 

There is a list of templates from which to choose. The preview section of the 
dialogue box displays a picture of how the browser window is displayed. 

3. Select Banner and Contents 
4. Click OK to set the Frames Page. 

Tip 

The 
description 
box is only a 
suggestion. 
You may put 
any 
information 
you desire 
into the 
frame. 
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There are now three frames on the screen. For the purpose of this instruction, we 
will refer to each of the frames as follows: The top frame is the Banner, the 
bottom right frame is the Main, and the left frame is the Contents. 

Editing Frames 
There are no set rules for the information that can be inserted into a frame. Once in the 
frame set is chosen, the borders may be moved and sized to suit the needs of the developer. 
For instance: the banner frame may also contain a series of navigational buttons. 

Exercise – Editing Frames 
1. On the Main Frame (bottom right frame) click Set Initial Page. A Create 

Hyperlink dialogue box will appear  
2. Locate and select aircraft.htm. 
3. Click OK. The Aircraft page will load into the frame. 
 

Next, we will adjust the Shared Borders on the page. For this exercise, it is not necessary to 
have the top border or any side borders in the Main Frame. We do want to keep the 
bottom border. The bottom border contains some navigation information we want to keep. 

 
4. On the Tools Menu, trace to and select Shared Borders. The Shared borders 

dialogue box will appear 
5. Select the Set For This Page Only option 
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Note: be careful not to select the “Use Web Default” option, which would change 
all of the pages in the web, and would undo much of the work we have already 
accomplished. 
 
6. De-select the Top checkmark to remove the top border.  
 

 
7. Click OK to apply the changes. The top border disappears. 

Next, we will remove the background image from the Main Frame. We will add a 
background later in this module to the other frames. 

8. On the Format Menu, trace to and select Background. 
9. In the Page Properties dialogue box, de-select (uncheck) the Background 

Image checkbox. 
10. Click OK to apply the change and close the dialogue box.  

Often times a web developer wants to try to avoid too may scroll bars in a frame. This is 
particularly true when the eventual plan is to create borderless frames. To help accomplish 
this, we will reduce the width of the information in the frame. In this case, the information 
is in a table, so we will simply reduce the width of the table. 

11. On the Table Menu, trace to and select Table Properties. The Table 
Properties dialogue box will appear. 

12. Under the Minimum Size area, Specify the width to 500 Pixels. 
13. Click OK to apply the change. 
14. Repeat the previous step for the Shared border table at the bottom of the 

frame.  
 
Note: To make the shared border table the active table, scroll the frame up and 
click anywhere inside the table. 
 
15. In the Banner Frame, click New Page. The frame will change to a white 

background. 



 

 3939 

16. From the Main Frame, Cut the bolded words Aircraft, and Paste them into 
the Banner page. To make the banner page the active frame, simply click 
anywhere inside it.  

17. Center the text “Aircraft” and increase the font to fit the frame. You may also 
wish too bold the text as well. 

18. In the Contents Frame (left frame) click New Page. The background will 
change to white 

19. From the Main Frame, Cut and Paste the Bulleted List of aircraft types into 
the Contents Frame. 

20. In the Main Frame, clean up any extra remaining paragraph returns or bullet 
marks by deleting them. 

 
Note: You may need to select the Show/Hide tool from the tool-bar to make the 
functions visible. 

We have now created four Pages: (1) Frames page, (2) Main Page, (3) Banner Page (4) 
Contents Page. The next phase is to add in links and target them. 

Adding targeted pages to frames 
Targeting frames is an important aspect of using frame sets. The choice of the frame in 
which information appears is vital to the overall “Look” the developer wishes to achieve. 

Targeting is simply telling the browser what frame to use to display information. 

If you are intending on targeting hyperlinks from one frame, to display in another frame, 
there are two key  points to consider: 

♦ Will this link use another page in the current site (such as a Contents Frame)? 
In this case, it is easy to adjust the information displayed. You can resize and 
manipulate the information displayed, because you are developing it. 

          

Tip 

For more 
information on 
using 
Targeted 
Hyperlinks 
with frames, 
see chapter 
10 of 
FrontPage 
Unleashed 
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♦ Will this link take the viewer to another web site (such as a “Link to other sites” 
Frame)? In this case, it is it is important to determine if the site you intend to 
link to uses framing. We do not want to “frame the user” into a corner. You 
may want to set the targeting to load a whole new page in this case. 

 
For our exercise, we will only be setting the hyperlinks to use pages that we have created on 
our web site. 

Exercise - Targeted Pages and Frames 
1. In the Contents Frame, Highlight the first item on the Bulleted List. 
2. On the Tool-bar, click the Create or Edit Hyperlink tool. The Create 

Hyperlink dialogue box will appear. 
3. Locate and Double click the Aircraft folder to open it. 
4. Locate and highlight the matching htm page for the listed bullet. (In this 

case, it should be the hc-130.htm).  
5. In the Target Frame portion, click the Change Target Frame Icon . The 

Target Frame dialogue box will appear. 
6. In the Current Frames Page Picture, click on the Main (bottom right) frame. 

It will turn from Grey to blue. 

 
Note: Take note of the “Target Setting” portion of the dialogue box.. “Main” 
 
7. Click OK in the Target Frame dialogue box, then OK in the Create Hyperlink 

Dialogue box. 
 
It is a good practice to test the hyperlinks right in the FrontPage Editor to be 
certain both the links and the targeting are correct. 
 
8. Press CTRL while clicking on the new Hyperlink. The Main Frame will 

change to the page you selected in the Hyperlink. 
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9. Repeat the same procedure to create hyperlinks for the remaining bulleted 
items in the Contents Frame. 

 
Now that the Hyperlinks are in place, the next phase is to fine tune the frames and enhance 
the appearance. 

Enhancing the framed pages 
The final phase of creating framed pages is to use many of the features we have already 
learned. The ultimate plan is to create a borderless frame set. Keeping this in mind, we can 
now move on to accomplish this goal. 

Exercise - Adding background 
In this exercise, we will add the background to the Banner and Contents frames. 

 
1. Click anywhere inside the Banner Frame to make it the active frame. 
2. On the Format Menu, trace to and select Background. The Page Properties 

dialogue box will appear with the Background Tab already selected. 
3. Click inside the Background Image Box.  A check mark should appear.  
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4. Click the Browse button, then locate and select the image Stripe.gif in the 
Images folder.  

5. Click OK to back out of the dialogue boxes. The background is applied to the 
Banner Frame. 

6. Repeat the process to set the background image for the Contents Frame.  

 

Creating Borderless frames. 
FrontPage makes adding and removing borders as simple as a few clicks of the mouse. 
Removing the borders will give our frames a smooth, seamless look. 

Scrollbars can divide borderless frames and seem to undo the seamless look we are 
attempting to achieve.  There is no way to control the size of the window the user is using 
to browse our site. Hence, it is nearly impossible to know if scrollbars will be visible or not. 
There is a function within FrontPage, which will allow the developer to specify if scrollbars 
are visible. Keep in mind that we may not want to turn scrollbars off. Otherwise, the user 
may not see all the information that the developer intended. 

Exercise – Creating borderless frames 
1. In the Frame Menu, trace to and select Frames Page Properties. The Page 

Properties Dialogue Box will appear. 
2. Remove the check mark from the Show Borders box and click OK. The 

borders are removed. 
 

Tip 

To specify 
scrollbar and 
sizing, view 
the Frame 
Properties for 
each frame. 
For more info 
see chapter 10 
of FrontPage 
Unleashed. 
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Note: In the FrontPage Editor view, it may still appear as if there are borders. These thin 
lines will not show when viewed from a browser or in the preview mode. They are there as 
a guide to show where the edges of the frames are located. 

To test your borders, select the preview tab at the bottom of the editor window.  

To remove the slider bar at the bottom of the Main Frame, It may be necessary to edit the 
pages in the frame. There are many ways to accomplish this task. One of the most common 
ways is to reduce the width of the table the information is located, or place the information 
into a table, then reduce the width. Remember that we cannot control what size window 
the user will be using to view, so we may not have any control over the slider/scrollbars. 

The final step is to create a link to your new pages from the Index page. 
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Publishing Pages 
In order for others to view your site it must be posted to a server.  Basically, everything in 
your web needs to be copied to the server using an FTP program.  With FrontPage, there's 
a little more involved than simply copying files.  FrontPage does a lot of work behind the 
scenes and stores a lot of information in hidden directories.  In order for your web to work 
properly you need all those hidden directories transferred as well.  Fortunately the Publish 
command in FrontPage makes the process simple and doesn't require an additional FTP 
program.  

Additionally, many active elements and FrontPage components require you to use the 
Publish command in order to work correctly.  Often the active element uses an applet (mini 
application) that is created when you publish the site.  Active elements will be discussed in 
the next section. 

Publishing Locally 
Normally, you would publish to a web server, but often you will want to preview your site 
before it is published.  FrontPage comes with a Personal Web Server that is installed on the 
workstation just for this reason.  You can publish your web to the web server on the 
workstation to ensure that it is functioning correctly before you publish to real web server. 

Exercise 
1. Follow these steps to publish to the Personal Web Server. 
2. From the File menu choose Publish.  The Publish window will open. 
3. Check the box next to Publish Changed Pages Only . 
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4. Click the More webs button.  The Publish FrontPage Web window will 
open as shown below. 

 
5. Click arrow next to the the location field.  A menu will drop down. 
6. Select your workstation.  The workstation name will be in the format w089xx 

with 089 replaced with your workstation number.   
7. Once you have selected your workstation the location field should look similar 

to the example shown in Step 4, except where it says datasheets you should 
see the name of your web. 

8. Click in the location field after the name of your web. 
9. Delete the words copy_of_yourweb .   
10. Type the name of your web.  When you are done your screen should look like 

the example below. Your workstation name will be slightly different and your 
web name will be different. 

 
11. Write this information down. This is the URL for your site. 
12. Click OK. 
 

Exercise ontinues on next page. 
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13. The following window will open: 

 
14. Enter Admin as the Name .  (This is case sensitive.) 
15. Enter password as the Password. (This is case sensitive.) 
16. Click OK. 
17. Your web will be published to the workstation's Personal Web Server. 

The next time you publish your pages you will not have to enter a name and password, 
unless you quit FrontPage. 

Exercise - Viewing Your Web 
To view your web, follow these steps. 

1. Open Internet Explorer. 
2. In the Address field type in the URL of your site.  You should have written 

this down in Step 11 of the previous exercise. 
3. Press Enter. 

Your site should load. 

Publishing to a Web Server 
Coast Guard Internet 
Currently OSC is not permitting users to publish FrontPage webs to the server.  Files must 
be copied to the server.  As discussed earlier, you are not allowed to include active elements 
or FrontPage components in web pages posted to the Coast Guard Internet server.  The 
base webmaster is the only person authorized to post pages to the server. 

CGWEB 
The Training Center web server does support FrontPage publishing.  Only authorized 
pagemasters will be allowed to publish pages to the server, although many people will be 
able to create pages.  Specific instructions on how to publish to the server will be given to 
the pagemasters on how to publish.  For more information contact the pagemaster for your 
office or the webmaster directly. 

 



 

 4747 

Enhancing Sites 
FrontPage offers a variety of active elements, components, and templates that you can use to 
enhance your site and speed up development without having to know programming or scripting.  
A full discussion of these enhancements is not possible in the scope of this course, so we are 
going to focus on a few.   If you would like more information on these and other enhancements, 
please refer to the pages noted in FrontPage 98 Unleashed.   

Hit Counter 
Hit counters allow you to get an idea of how many times your site has been accessed.  Hit 
counters do not provide an accurate number of visitors because server log files don't track 
visitors, rather they track how many times a page is requested.  So every time someone refreshes 
your page, it adds another hit.   

For more information on hit counters see page 216 in FrontPage 98 Unleashed. 

A word of caution - don't over use hit counters.  They are only needed on your homepage or 
major section pages. 

Exercise 
In this exercise you will add a hit counter to the index.htm page of your web. 

1. Open index.htm in FrontPage Editor. 
2. Place the insertion point at the bottom of the page, but not in the bottom border. 
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3. From the Insert menu, trace to Active Elements and choose Hit Counter.  The 
Hit Counter Properties window will open, as shown below. 

 
4. Select your desired number style. 
5. Click OK. 

A placeholder for the hit counter will be inserted into your page.  You will not be able to view the 
counter until you publish the pages. 

Hover Buttons 
Hover buttons are buttons that change when the mouse moves over them.  This can be done 
with Javascript, but FrontPage makes it much easier.  FrontPage actually writes the script for you.   

For more information on hit counters see page 225 in FrontPage 98 Unleashed. 

Exercise 
In this exercise you will create hover buttons that will link to the section index pages.  These 
buttons will be placed on cutters.htm , boats.htm, aircraft.htm, and history.htm. 

1. Open cutters.htm in FrontPage Editor. 
2. Delete the navigation bar in the second cell of the table in the body of the page.  This 

is the navigation bar that links to the other section index pages. 
3. With the cursor still in the same cell, click the Insert menu. 
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4. Trace to Active Elements and select Hover Button.  The Hover Button window 
will open as shown below. 

 
5. In the Button text field enter Aircraft. 
6. Click the Browse button. The Insert Hyperlink window will open. 
7. Locate the aircraft.htm file and click OK. 
8. Set the following options: 

Button color - Navy 
Background color - Default 
Effect - Glow 
Width - 90 
Height - 24 

9. Click OK.  The hover button will be inserted. 
10. Repeat steps 3-9 using the following information: 

Button Text Link to 

Cutters cutters.htm 
Boats boats.htm 
History history.htm 

When you are done you should have hover buttons for each section index page. 

Practice 
To practice creating hover buttons repeat the previous exercise on each of the following pages: 

♦ cutters.htm 
♦ boats.htm 
♦ history.htm 
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Table of Contents 
On a large site, a table of contents or site map can help people find their way through the site.  
FrontPage can create a text-based table of contents for every page in your site.  This table of 
contents is based on the Navigation view in FrontPage Explorer. 

Exercise - Table of Contents 
In this exercise you will create a new page containing a Table of Contents. The file cutters.htm 
will be used as a template for the new page. 

1. In FrontPage Editor open cutter.htm. 
2. From the File menu choose Save as.  The Save as  window will open. 
3. Be sure you are saving to the root of your web. 
4. Change the URL to toc.htm. 
5. Change the Title to Site Contents. 
6. Click Save.  The file has now been saved as toc.htm.   
7. Delete the contents of the third cell of the main table.   
8. While still in the cell, click the Insert menu. 
9. Trace to Table of Contents. The Table of Contents Properties window will open, 

as a shown below. 

 
10. Be sure the settings are the same as shown above. 
11. Click OK.  A table of contents placeholder will be inserted into the page. 
12. Save the file and preview it in Internet Explorer. 

 

 
 


